Advertisements
Aquatic Avenue Banner Tropica Shop Banner Fishy Business Banner
Results 1 to 4 of 4

Thread: Water feature not working in paludarium

  1. #1
    Join Date
    Sep 2014
    Posts
    419
    Feedback Score
    2 (100%)
    Country
    Singapore

    Water feature not working in paludarium

    Advertisements
    Fresh n Marine aQuarium Banner

    Advertise here

    Advertise here
    Need some help here,

    Was away for 9 days and my tank was empty and dry.
    After which, I tried to top up water but it seems the pump is dead.

    This tank, I actually paid someone to do it for me hence don't know the structure..

    Any advise or kind soul that willing to help?
    Bean + Kurt

  2. #2
    Join Date
    Jul 2008
    Location
    Tampines
    Posts
    34
    Feedback Score
    1 (100%)
    Country
    Singapore

    Re: Water feature not working in paludarium

    Maybe trapped air in the impeller chamber. Maybe want to try using a eye dropper and squirt some liquid into the chamber (through the water intake) to get it going? if only you can access the pump intake.

  3. #3
    Join Date
    Aug 2002
    Posts
    595
    Feedback Score
    0
    Images
    120
    Country
    Singapore

    Re: Water feature not working in paludarium

    If the pump has been running dry for long periods of time, it could overheat and cause damage to the motor/impeller.

  4. #4
    Join Date
    Nov 2002
    Location
    Singapore
    Posts
    1,665
    Feedback Score
    1 (100%)
    Images
    1
    Country
    Singapore

    Re: Water feature not working in paludarium

    Is the pump still working? apicture tells a thousand words.. send us a picture please

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •